Have the same issue. Since no one updates backtraders code anymore, I will install a python3.9 virtual environment using anaconda. On the long run, I need am actively maintained replacement for backtrader.