For code/output blocks: Use ``` (aka backtick or grave accent) in a single line before and after the block. See:

Tensorflow with Backtrader

  • Hello all,

    first tests with Backtrader works fine, and a sample-strategie can be backtested via IB-API.
    It is installed by GitHub-Download and "python install" on top of Python=3.8.5

    Now Tensorflow needs to be added and requirements need to be exactly fullfilled.
    Due to my admin-experiences I am very exact with versions, just to avoid hellfire caused by version-inaccuracies even when it worked fine in first place.

    With Backtrader and Tensorflow there is now a conflict in requirement that is a not solvable in a satisfying way:

    It sais:
    "Backtrader-requirements: Python 3.2 / 3.3/ 3.4 / 3.5"

    Tensorflow-requirements: Python 3.5–3.8

    Sounds ok with 3.5
    ...but when installing Tensorflow ontop of Python=3.5 "conda" can install only Tensorflow 1.10.
    And when explicitly installing Tensorflow=2 it says, it needs Python 3.6


    Therefore 3.6 is essential.
    But is this ok for Backtrader?
    How strict are the requirements for Backtrader?

    Just read about
    1.) There is sais even 3.7 is ok for backtrader2, but this GitHub-Repository is just a copy and not yet vaild?
    2.) Can I install Backtrader on Python=3.6? Anyone has experiences with this?

    Thanks alot!

  • Backtrader is tested for up to 3.7.

  • Perfect thx!

Log in to reply