For code/output blocks: Use ``` (aka backtick or grave accent) in a single line before and after the block. See: http://commonmark.org/help/

Remove resampled data lines from chart plot



  • Re: how to disable plotting resample data

    Hi - I've spent hours trying to figure out how to remove the 'linescoupler' lines on the chart (I have 4 timeframes, so chart is basically unreadable without removing), but no luck. I've referenced a prior thread on this, and tried all recommendations, but am still having issues. I'm also a python rookie, so please take it easy on me :)

    Here's my code:

    cerebro.adddata(data=data)
    				
    #Apply resamplings			
    myresample = cerebro.resampledata(data,
    timeframe=bt.TimeFrame.Minutes,
    compression = Tickers.timeframes()[1])
    
    myresample.plotinfo.plot = False
    

    I added 'myresample.plotinfo.plot = False'', but lines are still on chart
    I also tried 'plot=False' within the cerebro.resampledata construct also, but it errors out.

    Not sure what else to do, but would really appreciate your help. Aside from that, i absolutely love your system/framework -thanks for all your hard work on this.


  • administrators

    Let's try to approach why what you posted cannot allow people to help you (you say you are a rookie and everybody has been there)

    Title

    Remove resampled data lines from chart plot

    Description:

    I've spent hours trying to figure out how to remove the 'linescoupler' lines on the chart

    But there is nothing later in the post that show what linescoupler have to do with the problem.

    Core of the problem

    so chart is basically unreadable without removing

    There is even no chart, so we don't know how your problem looks like.

    Furthermore, if you have a problem, try to simplify it

    I have 4 timeframes

    Work with 2 and with a sample which is crystal clear. Because this isn't:

    @esondrstd said in Remove resampled data lines from chart plot:

    myresample = cerebro.resampledata(data,
    timeframe=bt.TimeFrame.Minutes,
    compression = Tickers.timeframes()[1])
    

    It's not even properly formatted for python code, which means it's not part of actual working code.

    Summary

    • The title and the description talk about different things
    • There is no chart and the problem seems to be related to charting
    • The code belongs to a complex scenario (simplify it!)
    • The code snippet is not complete and actually not from working code

    It is fully understandable that when you put a lot of effort into something (including debugging your own problem during several hours) you want to get your thoughts out and see if someone can help, but it's not the best moment and you need to slow down and work also on the presentation of the problem (which is not easy because you are tired, having worked on the actual problem)

    If you have a problem showing your code (your IP) and the data, use the sample data from the repository and produce a small clean sample with something like Timeframe.Days and Timeframe.Weeks and a linecoupling that shows your problem. Being a rookie, working on such a sample will be helpful for you.



  • Thanks for your quick response, and in hindsight, realize my request was very unclear without additional context (or fully functioning code). The good news is I actually figured it out (the line coupler lines on the chart were from the pivot point indicator, which i just disabled). Thanks again!