@jrothschild33 said in How to process data by quarter?:

You have to make sure the data is started on January,or the result will only compression by 3 continuous months, not by quarter.

AFAIU this is the only option right now. Properly solving this should involve extending Backtrader to support yet another TimeFrame with all the ensuing consequences.

Others may correct me of cause.